Импорт товара

<< Click to Display Table of Contents >>

Navigation:  Руководство пользователя >

Импорт товара

Previous pageReturn to chapter overviewNext page

Часто возникает такая ситуация, когда поставщик товара предоставляет накладную в виде документа Excel, которую требуется оприходовать в Вашем магазине. Для таких случаев существует функция Импорт товара, с помощью которой очень просто можно осуществить импорт приходуемого товара, программа автоматически (после определенных действий) подставляет те данные, которые находятся в импортируемом файле.

Для начала импорта файла, заходим в пункт меню Документ - Приход товара - Добавить кнопка Добавить (Рис. 1).

приход - импорт

Рис. 1

 

Вам необходимо перенести данные из сохраненного файла в программу, для чего при создании прихода, на форме редактирования Приход, нажмите кнопку Импорт.

Откроется окно Импорт, где есть две вкладки: Настройки импорта (Рис. 2) и Товар (Рис. 3).

Импорт товара

Рис. 2 (Версия программы 2019.4.2)

 

Импорт товара - вторая вкладка

Рис. 3 (Версия программы 2018.3.0)

 

Для создания подключения к документу необходимо нажать на кнопку Источник данных кнопка Источник данных.

В открывшемся окне Свойства канала передачи данных, на закладке Поставщик данных будет выделена строка, не изменяйте ее, нажмите кнопку Далее (Рис. 4).

Свойства канала передачи данных

Рис. 4

 

Появится окно на закладке Соединение. Включите переключатель Использовать строку соединения, поле под переключателем станет доступным для ввода, также станет активной кнопка Сборка (Рис. 5). Нажмите на нее.

Свойства канала передачи данных - Клиенты - Соединение

Рис. 5

 

Откроется окно Выбор источника данных (Рис. 6), где Вы должны нажать кнопку Создать правее поля Имя DSN.

Выбор источника данных - Клиенты

Рис. 6

 

Если импортируемый документ создан в Exсel, выберите строку для Exсel, как указано на Рис. 7. Справка. Выбирайте тот драйвер, в котором указано больше всего расширений файлов.

Создание нового источника данных - Клиенты

Рис. 7

 

Затем нажмите кнопку Далее. Откроется окно (Рис. 8).

Создание нового источника данных2 - Клиенты

Рис. 8

 

Введите любые значения, например "12" (временное имя файлового источника). Нажмите Далее, в появившемся окне (Рис. 9) нажмите на кнопку Готово. По нажатию на эту кнопку будет создан файловый источник данных.

Создание нового источника данных3 - Клиенты

Рис. 9

 

В открывшемся далее окне Установка драйвера ODBC для Microsoft Excel (Рис. 10) нажмите на кнопку Выбор книги.

Установка драйвера - С выбранной книгой

Рис. 10

 

После этого, откроется окно Выбор книги, где Вы должны указать файл, который нужно импортировать (Рис. 11).

Импорт клиентов - Выбор книги

Рис. 11

 

Для выбора файла в поле Каталоги укажите папку, в которой находится файл. В поле Имя базы данных отобразятся файлы, содержащиеся в выбранной папке. Укажите нужный файл и нажмите ОК.

В окне Выбор источника данных отображается в поле Имя DSN - созданный Вами источник данных. После чего нажмите на кнопку ОК (Рис. 12).

Выбор источника - 12

Рис. 12

 

В следующем окне Установка драйвера ODBC для Microsoft Excel нажмите ОК. В уже знакомом окне Свойства связи с данными отобразится запись указанного файла для импорта (Рис. 13).

Свойства канала передачи данных - Строка соединения - Клиенты

Рис. 13

 

Нажмите кнопку ОК и Вы вернетесь на форму Импорт (Рис. 14), где в поле Список импортируемых файлов будет прописан путь к импортируемому файлу.

Импорт товара - вкладка Настройки импорта

Рис. 14 (Версия программы 2019.4.2)

 

Доступно три способа импорта документа:

1. Использовать выделенную область данных (таблицу) (Рис. 14 (2)) - необходимо в импортируемом документе выделить область таблицы, которую Вам нужно импортировать и ввести (изменить) имя таблицы в поле в левом верхнем углу окна. В данном случае Таблица (Рис. 15). Сохраните документ. Стоит отметить что поля, которые указаны в импортируемом файле необходимо указывать в программе. Поля, которые доступны в программе можно увидеть на фото (Рис. 3).

Импорт товара - Эксель

Рис. 15

 

При выборе такого способа в поле Таблица (Рис. 14 (4)), введите название таблицы, которое Вы внесли в импортируемый документ (выберите из выпадающего списка).

2. Использовать указанный диапазон ячеек вида (A1:Z33) (Рис. 14 (2)) - данный вариант используется для файлов импорта, которые содержат данные в указанном диапазоне ячеек. Удобно использовать для файлов, который содержат какой-либо заголовок. Требует указания диапазона ячеек с данными (координаты верхней левой и нижней правой ячейки с данными). В Поле Таблица (Рис. 14 (4)) укажите название листа импортируемого документа

3. Загружать все данные с листа (Рис. 14 (3)) - вариант является универсальным и используется в том случае, если данные для импорта не содержат ничего "лишнего". Данными для импорта является всё содержимое листа Excel, независимо от того, где они находятся. Программа автоматически загрузит заполненное содержимое, требуется указать только лист с данными в поле Таблица (Рис. 14 (4)).

На вкладке Настройки импорта укажите необходимые настройки:

1) В поле Метод формирования наценки (Рис. 14 (5)) указать, от куда будет браться наценка на товар:

По наценке импорта - при расчете отпускных цен, соответствующая (розничная/оптовая) наценка берется из настроек импорта;

Товар-Вид товара-Наценка импорта - при расчете отпускных цен, берется соответствующая текущая наценка у товара (в карточке товара), если она отсутствует (новый товар), тогда из вида товара. Если в виде товара не установлена соответствующая наценка, тогда отпускная цена рассчитывается аналогично методу "По наценке импорта".

2) Переключатель Генерировать собственные штрих-коды при отсутствии (Рис. 14 (6)) - выполняет проверку поля штрих-код, если в поле не стоит значение, тогда программа автоматически присваивает новый тому товару, в котором его нет.

3) Переключатель Добавлять новый товар в справочник (Рис. 14 (7)) - отвечает за то, будет ли новый товар отображаться в Полном списке товаров и услуг, которые когда-либо были оприходованы во всей торговой сети.

4) Переключатель Обновлять параметры товара (Рис. 14 (8)) - при включенном переключателе, если товар найден по одному из указанных параметров поиска, наименование товара будет обновлено в соответствии с импортируемыми параметрами.

5) Переключатель Фиксировать изменение цены закупки (Рис. 14 (9)) - при импорте товара будет получена и зафиксирована предыдущая закупочная цена, если товар был ранее оприходован (замедляет процесс импорта товара).

Есть возможность загружать несколько документов одного поставщика. Для того, чтобы импортировать несколько файлов, необходимо, чтобы они были одинаково размечены (есть выделенная область с одинаковым названием, которая содержит выбранные колонки).

Кнопка Выбрать файл Excel Импорт товара - Настройки импорта - Добавить параметры поиска (область Список импортируемых файлов) служит для добавления файла в список. Первый файл в списке является основным документом, из которого формируется список таблиц и колонок. Если в файле отсутствует таблица, либо выбранная колонка, то такие документы загружены не будут.

В случае, если необходимо удалить файл из списка, используйте кнопку Удалить Импорт товара- Настройки импорта - Удалить параметры поиска.

С помощью кнопки кнопка Открыть документ (Импорт товаров) можно открыть указанный файл внешним редактором.

При активированной настройке Импортировать каждый файл в отдельный документ прихода (Рис. 14 (10)), для каждого файла будет создана отдельная приходная накладная, а товары основного документа будут добавлены в основной документ прихода (посмотреть созданные приходные накладные можно в пункте меню Склад - Список приходов). Если данный переключатель выключен, тогда товары со всех документов будут загружены в один приход.

После завершения импорта, выводится сообщение с информацией о итогах импорта.

Настройка Фиксировать название товара (Рис. 14 (11)). При импорте товара будет формироваться краткое название товара, если настроено правило формирования краткого названия товара в Настройки - Параметры - Товар - Наименование.

 

С помощью поля Параметры поиска товара можно добавлять методы поиска. По нажатию на кнопку Импорт товара - Настройки импорта - Добавить параметры поискаоткроется окно Параметры поиска товара (Рис. 16)

Параметры поиска товара - Импорт товара

Рис. 16 (Версия программы 9.2.10)

 

В параметре поиска можно указать:

Поиск по названию товара (сформированное по алгоритму системы);

Поиск по совокупности полей (например, искать по Цвету и Материалу). С помощью кнопки Выбор значений (Импорт товара) можно Выбрать все параметры или Отменить выбор.

После выбора параметров поиска, жмем Записать.

Последовательность параметров поиска можно менять, используя кнопку перемещения вверхИмпорт товара - Настройки импорта - Вверх параметры поиска(вниз Импорт товара - Настройки импорта - Вниз параметры поиска ).

 

Далее переходим на вкладку Товар (Рис. 17).

Импорт товара - вторая вкладка

Рис. 17 (Версия программы 2019.0)

 

В полях панелей Описание товара и Количественные характеристики товара выберите из выпадающего списка соответствующие им поля импортируемого документа. Добавлена возможность импортировать параметр Сезон.

 

Можно обновлять параметры товара при импорте товара на основании данных существующего товара. Например, можно обновить параметр код УКТ ВЭД, используя файл импорта только со списком штрих-кодов, к каждому из которых соответствует код УКТ ВЭД.

 

При импорте эквивалентных цен в валюте, если не указана розничная/оптовая цена в национальной валюте, то она будет рассчитана из соответствующей эквивалентной цены по курсу приходной накладной. Данные в файле импорта являются первичными при добавлении товара в приходную накладную. То есть, если цены импортируются из файла, то будут сохранены именно они, а не пересчитанные (например, если цена в эквиваленте не импортируется, то она пересчитывается автоматически из соответствующей цены в национальной валюте). Стоит отметить, что если при импорте валютной приходной накладной указать закупочную цену в национальной валюте, но НЕ указать закупочную цену в валюте накладной,  то приходная накладная не будет содержать закупочных цен, хотя наценка будет рассчитана.

Переключатели Округлять. Если активирован, то значение соответствующего поля при импорте будут округлены до целого. При этом:

если эквивалентные цены не импортируются, то округлены они не будут. Они могут быть рассчитаны из округленных цен продажи;

если эквивалентные цены импортируются, а цены продажи нет, то цены продажи будут рассчитаны из неокругленных эквивалентных цен, а затем округлены.

При импорте товара в приходную накладную в национальной валюте в зависимости от настройки Автоматически рассчитывать эквивалент цены продажи в валюте анализа (Настройки - Параметры - Фин.анализ):

1.Активирован переключатель Автоматически рассчитывать эквивалент цены продажи в валюте анализа. В этом случае, если в импорте:

не указана цена продажи и указан эквивалент - товар в документе прихода не будет содержать цену и не будет содержать эквивалента;

указана цена продажи и указан эквивалент - товар в документе прихода будет содержать цену и будет содержать эквивалент в валюте анализа, равный импортируемому значению;

указана цена продажи и не указан эквивалент - товар в документе прихода будет содержать цену и будет содержать эквивалент в валюте анализа, рассчитанный по сохраненному курсу валюты анализа.

2.Выключен переключатель Автоматически рассчитывать эквивалент цены продажи в валюте анализа. В этом случае:

не указана цена продажи и указан эквивалент - товар в документе прихода не будет содержать цену и не будет содержать эквивалента;

указана цена продажи и указан эквивалент - товар в документе прихода будет содержать цену, не будет содержать эквивалента;

указана цена продажи и не указан эквивалент - товар в документе прихода будет содержать цену и не будет содержать эквивалент.

 

Стоит отметить, что поля Вид товара и Производитель могут быть привязаны к полям Родительский узел вида товара и Родительский узел производителя. Если в импортируемом файле есть вид товара, либо производитель, которого нет в Вашей торговой сети, можно воспользоваться соответствующим Родительским узлом, в который будет записан новый вид, либо производитель, что значительно облегчает дальнейшее означивание товара (см. ниже). В случае, если вид товара или производитель уже существует в Вашей торговой сети, тогда выбираем в соответствующем Родительском узле необходимый, программа автоматически будет присваивать товар к выбранным узлам.

Расчет отпускных цен осуществляется, если пользователь ввел % наценки для розничной цены, выбрано поле "Закупочная цена", а "Розничная цена" нет - аналогично и для оптовых цен.

Поля Розничная и Оптовая цена предназначены для того, если в импортируемой таблице есть розничные, либо оптовые цены, была возможность устанавливать необходимый процент наценки.

После указания всех необходимых настроек, нажмите кнопку Записать. Вам будет предложено сохранить описание подключения, сохраните его.

Товар из внешнего документа запишется в приход в программе.

По нажатию на кнопку Открыть кнопка Открыть (Импорт товаров) можно загрузить файл описания. Данная загрузка служит для того, чтобы не указывать заново соответствие столбцов в импортируемом файле и в получаемой таблице.

 

Обратите внимание! В случае, если происходит некорректных импорт строк (например, некорректно импортируются числа), при импорте всех строк можно использовать макрос For Each cell In Selection: cell.Value = "'" & cell.Value: Next: , который добавляет апостроф перед числом тем самым делая число записанным как текст. Для этого выделите все строки и выполните макрос.

В случае, если в документе импорта есть колонки, содержащие и текст, и числа (например, Артикул 78549-АР - текст, 440 - число), то для корректного импорта необходимо выполнить следующие действия:

1.Сохраните файл импорта Excel в формате *.txt. Закройте файл

2.Далее в документе Excel перейдите в меню Файл и выберите пункт Открыть (Рис. 18 (1)).

3.Выберите сохраненный ранее в формате *.txt файл импорта. Для того, чтобы при выборе были доступны все необходимые файлы, следует выбрать настройку отображения Все файлы (Рис. 1 (2)). Выделите файл и нажмите Открыть.

Файл - Открыть - txt

Рис. 18

 

4.В открывшемся окне Мастер текстов (импорт), перейдите к Шагу №3 (Рис. 19).

Мастер текстов - формат текстовый

Рис. 19

 

5.В данном окне необходимо всем полям, которые могут содержать как текстовые значения, так и числовые установить Формат данных столбца - текстовый (выделить необходимую колонку в образце разбора данных и установить настройку текстовый) и нажать Готово.

6.Далее сохраните файл в формате Excel.

7.Перейдите к импорту файла в программе Торгсофт.

 

Импорт динамических характеристик товара

Если в описании товара есть динамическая характеристика со значением чек-бокс (галочка), то в импортируемом файле Excel в колонке с динамической характеристикой значение установленной или не установленной галочки должно быть 1 или 0 соответственно.

 

Если введенный товар не привязан к справочникам видов товара, производителя, сезона.

Означивание справочников производится на панели Товароведение - Диагностика ошибок (более подробно о диагностике ошибок), закладке Означивание справочников (Рис. 20).

Диагностика ошибок - Означивание справочников

Рис. 20

 

Возможно устанавливать значения для вида товара, производителя и сезона, как для одного товара, так и для выделенной группы товаров.

Операция присвоения и изменения значений привязок к справочникам, производится с помощью кнопки Изменить. Перед этим необходимо выделить товар или группу товаров с помощью приемов многострочного выделения. В случае редактирования, для группы выделенных товаров появляются переключатели Записать, если нет информации напротив полей: Вид товара, Производитель, Сезон (Рис. 21).

Означивание справочников товара

Рис. 21

 

Укажите значения в полях для нужных справочников и нажмите кнопку Записать кнопка Записать.

Выделенный для означивания товар будет привязан к указанным значениям справочников.